Java中使用jrebel实现热加载启动时groovy报错的解决办法。

码云
2020-12-08 13:13

Java项目中使用了Springboot和jrebel热加载,之前都能正常的运行。后面引入groovy 3.0.3版本的jar包以后报错:error class 'groovy.lang.metaclassimpl' could not be processed by org.zeroturnaround.jrebel.groovy.cbp.metaclassimplcbp。

问题分析:导致这个问题的原因在于groovy版本过高,jrebel没有支持,改成groovy低版本jar包(如:groovy-2.5.4)后即可解决。

全部评论

相关文章