flutter中如何解决“Dart SDK is not configured”?

码云
2020-11-23 13:55

这个问题主要由于flutter工程没有配置Dart SDK导致,参考以下步骤解决:

  1. android studio中打开File->Settings->Language & Framework->Flutter (macos下:Android Studio->Preference->Language & Framework->Flutter)
  2. Flutter SDK path: 选择flutter的安装路径
  3. 点击OK后android studio会自动刷新,Dart SDK也会自动填充
  4. 如果还是会存在这个问题,那可以去下载一个Dart并安装
  5. ...Language & Framework->Dart 然后选择刚安装的Dart路径

 

根本上产生这个问题的原因的问题在于Dart SDK没有找到,不管是选择flutter安装目录还是安装Dart,都是让android studio间接或直接的找到Dart SDK。

全部评论

相关文章